Support Tickets - Push notifications

Push notifications

Live Chat 3 13.05.2017 156 Support Status: Closed Solution: Yes contactek


As you suggested I have gone to https://www.jakweb.ch/faq/a/162/native-app-android-and-ios

got a token and key, that I put in the settings of my livechat installation. However, I do not get push notifications when an online user whats to chat. I use an IOS device.

any suggestions?

thanks,


Replies (26)

  • avatar Jerome

    Please make sure you logged out of the chat. Using the business hours in your operator profile will put your chat online.

    Also make sure your operator profile accepts push notifications by having the mobile icon in a green colour.

    The system won't send a push notificaiton if you or another operator is logged in.

    13.05.2017 0
  • avatar contactek

    I completely logged out. Everything else is setup as you described 

    13.05.2017 0
  • avatar contactek

    My business hours are set from 00:00 to 23:59 for every day of the week

    13.05.2017 0
  • avatar Jerome

    A couple of questions:

    • Operator profile accepts Push Notifications?
    • cUrl is enabled on the server?
    • Push Token and Key are placed in the settings?
    • Push Token and Key match with the one on our push server?
    • Operator is logged out, app is closed or in the background?
    • Chat shows online and you start a conversation?

    Thank you for your feedback.

    13.05.2017 0
  • avatar contactek

    here is the error I get

    [13-May-2017 02:03:21 America/Ensenada] PHP Fatal error: Uncaught Error: [] operator not supported for strings in C:\inetpub\wwwroot\prestashop\livechat\rest\transfer.php:193
    Stack trace:
    #0 {main}
    thrown in C:\inetpub\wwwroot\prestashop\livechat\rest\transfer.php on line 193

    13.05.2017 0
  • avatar Jerome

    Yes, that has nothing to do with the push notifications.

    Can you please answer my questions?!

    13.05.2017 1
  • avatar contactek
    • Operator profile accepts Push Notifications? --- yes, the green phone icon is on... then I logged out of the web interface
    • cUrl is enabled on the server? - yes
    • Push Token and Key are placed in the settings? - yes
    • Push Token and Key match with the one on our push server? - yes
    • Operator is logged out, app is closed or in the background? - yes
    • Chat shows online and you start a conversation? -yes

     but, I started a conversation with a user (user initiated a chat, I found it in Que on the ios, and started chatting..

    thenk I opened another app on my iphone, and the user typed a message in the chat on the browser... I did not get a push on iphone... 

    13.05.2017 0
  • avatar Jerome

    Please check your settings again. The system will only send you push notification on an answer after a certain time you set in the settings. By standard this is 120 seconds. You will need to check following settings: "Send reminder via Push after x seconds".

    However you should have received a push notification when the app is closed or in the background and no operator is physically logged in. The app as soon you put it in the background or open another app will set your operator status to hidden, means the push notifications will start to work, as soon the app is back in the foreground the status is set to online and no push notifications will be sent.

    We pretty much use only our mobile phones (iOS and Android) and it works like a charm.

    13.05.2017 0
  • avatar Jerome

    Hi,

    how was your weekend?

    Does it work now for you?

    Thank you for your feedback.

    15.05.2017 0
  • avatar contactek

    hi, unfortunately does not work with push for me.. maybe we can do a screen share so you can see whats going on.

    Also, one thing I noticed.. when inside you app on IOS keyboard autocomplete does not function... maybe a security issue...

    16.05.2017 0
  • avatar Jerome

    Good Morning,

    Please send me access to your server via FTP and super operator login access to your Live Chat 3 installation.

    https://www.jakweb.ch/access-form

    Thank you very much.

    16.05.2017 0
  • avatar contactek

    Just sent... all the info

    16.05.2017 0
  • avatar Jerome

    Thank you very much.

    The operator login works great but for some reason I cannot login into the server via FTP. Please make sure that you log out from all your devices so I can truly test the push notifications and why it does not get send.

    Thank you very much.

    16.05.2017 0
  • avatar contactek

    look at my notes.. .look at the port number..  port 22

    16.05.2017 0
  • avatar Jerome

    I use port 22.

    16.05.2017 0
  • avatar contactek

    lets do screen share

    16.05.2017 0
  • avatar contactek

    actually, whats your IP address?  you maybe being blocked

    16.05.2017 0
  • avatar Jerome

    I need to modify some code to test the push notification and to check what your server is doing.

    My current IP is: 47

    16.05.2017 0
  • avatar contactek

    hmm.. your IP is not blocked...

    IP: 209.237.251.109 port 22

    use explicit FTP over TLS if available

    user: ftpuser-01

    16.05.2017 0
  • avatar contactek

    then pass as I provided.. what error are you getting?

    16.05.2017 0
  • avatar contactek

    any luck?

    16.05.2017 0
  • avatar Jerome

    Ok, fixed on your server. Your curl needed an extra parameter to make it work.

    Please logout from the app and login again to register your device, after that you should receive push notifications.

    We will implement that extra check within the next release.

    Thank you for your patience.

    16.05.2017 0
  • avatar contactek

    ok, thanks.. what about IOS keyboard?  the predictive text that can not be enabled.... have you experienced this issues?

    16.05.2017 0
  • avatar Jerome

    We will make that work within the next release of the iOS app as well. Thank you for your suggestion.

    16.05.2017 0
  • avatar contactek

    ok, got it.. no problem... thanks for fixing it... also, one more thing on IOS... when I reply the keyboard slides down... and I have to reactivate it again.. it would be good if keyboard did not hide after replying...

    thanks again

    16.05.2017 0
  • avatar Jerome

    Yes, makes sense.

    Should you have any further questions or problems, please open a new ticket.

    *** Ticket closed ***

    16.05.2017 0