Support Tickets - Undefined variable Error

Undefined variable Error

Live Chat 15.12.2016 263 Support Status: Closed Solution: Yes brkicz


My developer is getting these errors trying to install the script on the test server, any guidance?Notice: Undefined variable: jakdb in E:xampphtdocstechnochattinginstallinstall.php on line 683Notice: Undefined variable: jakdb in E:xampphtdocstechnochattinginstallinstall.php on line 707

Replies (20)

  • avatar Jerome

    Good Morning,

    That means he did not follow the manual. The manual is included in the download package or available here: https://www.jakweb.ch/docs/live-chat/

    Missing the complete file include/db.php with all information necessary.

    https://www.jakweb.ch/faq/a/98/full-site-domain

    https://www.jakweb.ch/faq/a/99/database-and-password-hash

    15.12.2016 0
  • avatar brkicz

    OK - that was done on their server, now they have uploaded to the production server (godaddy hosted) and here is another error. Please advise - tnx!

    "We have followed the instructions and installed the chatting module. But it does not appear in front end and dashboard url gives error. We have created a subdomain and named it as livechat. When we try this url: https://mobsgift.com/livechat/operator/ then we get the following error:

    Parse error: syntax error, unexpected ')', expecting :: (T_PAAMAYIM_NEKUDOTAYIM) in /home/brkicz/public_html/livechat/operator/dashboard.php on line 18

    We have updated define('FULL_SITE_DOMAIN', 'https://www.mobsgift.com');

    Note: we are using the same database as the website."

    16.12.2016 0
  • avatar Jerome

    Good Morning,

    Please read following FAQ article: https://www.jakweb.ch/faq/a/98/full-site-domain

    That is also stated in the manual and in the include/db.php file.

    The full site domain is the domain only in your case because you have stated the url without www. your full site domain should look like this:

    define('FULL_SITE_DOMAIN', 'mobsgift.com');

    Please also make sure to upload the files to your server never with cPanel, it will stuff up the permissions big time. More information here: https://www.jakweb.ch/faq/a/115/livechat-folder-and-file-permissions

    16.12.2016 0
  • avatar brkicz

    Thank you for the information.

    We followed the instructions. Updated site domain as mobsgift.com, set the file permission to 777 and 755, but none works.

    21.12.2016 0
  • avatar Jerome

    Please send me ftp and operator access via following form: https://www.jakweb.ch/access-form

    21.12.2016 0
  • avatar Jerome

    Hi,

    thank you for the information but they have nothing to do with us. FTP points into an empty directory and what should I do with this: https://www.mobsgift.com/admin_login?

    Thank you for your feedback.

    21.12.2016 0
    • avatar brkicz

      I believe godaddy requires configuration file to be sent as a security measure. filezilla/coreftp for windows or cyberduck (mac). Which one do you prefer and what email to send it to?

      21.12.2016 0
  • avatar brkicz

    disregard previous msg, try this jakweb2 - same password as previous one.

    21.12.2016 0
  • avatar Jerome

    Good Morning,

    The problem is your server does not meet the minimum requirements. It runs PHP 5.4 but it should have at least 5.5. Best is to run PHP 7.

    I have changed the dashboard.php file to make it work at least for the dashboard but you might run into other issues.

    http://mobsgift.com/livechat/operator/

    22.12.2016 0
  • avatar brkicz

    Thank you for your help. We have upgraded php to 5.6 and now it works. But there is style issue. It seems the module is trying to use css and js files through http. But we are using https in the website. That seems to be the issue. Please have a look at the screenshots:

    http://i68.tinypic.com/105o4ch.jpg
    http://i67.tinypic.com/2zr22xh.jpg

    Please help. Thank you.

    22.12.2016 0
  • avatar Jerome

    Please open your include/db.php file and change following line:

    // Set http or https
    define('JAK_SITEHTTPS', 0); // Site is running in HTTP 0 = / HTTPS = 1

    That way the software knows you are using SSL.

    22.12.2016 0
  • avatar brkicz

    Hello Jerome. That was nice of you. It worked.

    One last help. The chatting module looks fine in desktop, but it does not look good in phone. Is there anything we can do about it?

    Here is the screenshot: http://i63.tinypic.com/m9sgwl.jpg

    Thank you.

    22.12.2016 0
  • avatar Jerome

    If you have a lot of vistors from mobiles I would not use this button. Upload your own (smaller) or use the slide up chat it will detect mobile user and open the chat in a new tab instead of sliding up.

    You can easily upload your own buttons via operator panel.

    Play around with the widget options, upload your own buttons to find the best solution for your website. If nothing helps you can also edit following stylesheet css/clientchat.css

    22.12.2016 0
  • avatar brkicz

    Hi - I am not able to upload any *.PNG images. Trying to fix the appearance on mobile which does not look satisfactory with preloaded icons. Please assist. Also, would you be able to assist with the upgrade to 3.01 if possible? There are some stability issues with using the operator panel. Tnx a lot!

    31.12.2016 0
    • avatar brkicz

      Ok I have realized the upload issue was due to naming the files a specific way. The upgrade question is still on - I would like to update to 3.01 hoping it will fix some of the issues - your assistance is appreciated. I have clicked "install" but not sure if something has to be done on the back-end. You still have the FTP access I believe.

      01.01.2017 0
  • avatar Jerome

    Good Morning.

    Please update via Auto Updater: https://www.jakweb.ch/faq/a/97/auto-updater

    Two clicks.

    01.01.2017 0
  • avatar brkicz

    Happy New Year!

    Two clicks - sure, but it does not perform the last step for me. I get to "Update already downloaded" but it still shows Version 3.0.

    01.01.2017 0
  • avatar Jerome

    Well then you server configruation does not allow Auto Updates. You will need to update manually.

    Download the package from our download area and replace all files and then run the install/update.php wizard.

    Happy New Year.

    01.01.2017 0
  • avatar brkicz

    OK thanks.

    1. I want the users who enter the chat to have gender neutral avatar (right now they get assigned male character). I have selected - "Show avatars on client side - NO" but it is still showing auto assigned avatar.
    2. Is it possible to remove 3 char minimum for guest chat user name? Some people like to put initials which is usually just 2.
    01.01.2017 0
  • avatar Jerome

    Of course you can upload your own avatars, they stored under the folder files. The standard.png is the default avatar.

    To change minimum length you will need to edit the start.php file find:

    if (empty($jkp['name']) || strlen(trim($jkp['name'])) <= 2) {

    replace with:

    if (empty($jkp['name']) || strlen(trim($jkp['name'])) <= 1) {

    After that your clients will have the possibility to sign in with two characters.

    As this ticket is not private and has not much to do with the first question anymore I will close it. Should you have any further questions please open a new ticket.

    Thank you very much.

    01.01.2017 0