Support Tickets - Pro-active and regular messages don't work

Pro-active and regular messages don't work

HelpDesk 06.04.2016 513 Support Status: Closed Solution: Yes gilbenhorin


Hi there.

After upgrading to 1.4 (And then further on to 1.4.1 and 1.4.2) a very strange thing has happened.

Messages no longer display on the site where the embdedded code is integrated.

The chat box appears and the chat works fine, but neither the auto pro-active or manually sent messages appear in the site at all.

Please help!


Replies (13)

  • avatar Jerome

    Thank you for opening a support ticket.

    Could I please have the URL, where the message should load. It migh just be a browser caching problem.

    06.04.2016 0
  • avatar gilbenhorin

    In addition, when going to edit a user screen, if I attempt to put anything in the 'Invitation message' box and hit save, the system throws me out with the following message:

    MySQL Error:Unknown column 'usign' in 'field list'
    06.04.2016 0
  • avatar gilbenhorin

    site is http://www.benhorin.com

    06.04.2016 0
  • avatar gilbenhorin
    06.04.2016 0
  • avatar Jerome

    Something must be gone wrong on a update.

    You might want to run following SQL comand:

    ALTER TABLE user ADD `usign` MEDIUMTEXT NULL AFTER `invitationmsg`;

    Should you have set a database prefix you need to add it in front of the user.

    I can't see any Auto ProActive Message is set, could I have access to FTP and Operator panel, please? Send all the information with following form: https://www.jakweb.ch/access-form

    Thank you.

    06.04.2016 0
  • avatar gilbenhorin

    Ok. That fixed the issue for the invitation message in the user settings. Thanks. Sent the requested details over to you regarding the display of messages and auto-proactive.

    Thanks

    06.04.2016 0
  • avatar Jerome

    Thank you for the information.

    I have emptied your cache under maintenance and truncated the online user table, it works fine now.

    Please also check your Auto Proactive URL, because if you like to fire the Auto Proactive on the home page you have to set the url with a ending forward slash.

    Awaiting your feedback.

    06.04.2016 0
  • avatar gilbenhorin

    Hi Jerome,

    It worked once - for an instant message - but then didnt work after that. The auto-proactive doesnt show up at all - either for homepage (with trailing slash) or internal page.

    Also, when I close the client browser - there is session ghosting in the operator so that I still see as if the user is online - even though the client browser is shut. I have had up to 4 or more of these at a time - so I cannot tell which is the real me online...

    Thanks

    Gil

    06.04.2016 0
  • avatar Jerome

    The Auto Proactive only works once otherwise it would be really annoying. If you want to test it you have to remove the cookie.

    User online list will refresh after couple of seconds, it not removes the user on the same time he is leaving your site. That would be a performance killer.

    06.04.2016 0
  • avatar gilbenhorin

    Ok. how about the instant messages - do they also only work once? (when user is not logged in, but I want to send him a message). is that also only once?

    06.04.2016 0
  • avatar Jerome

    No that will fire each time you send it.

    I have just run a few tests on Chrome, Firefox, Opera and Safari and it always worked fine multiple times.

    What browser do you use for testing?

    Thank you for your feedback.

    06.04.2016 0
  • avatar gilbenhorin

    Chrome and Safari. Ok - I see now that it does indeed work. Thanks so much for all your help!

    06.04.2016 0
  • avatar Jerome

    Thank you for the feedback.

    *** Ticket closed ***

    06.04.2016 0