Support Tickets - Proactive and Contact form

Proactive and Contact form

Live Chat 3 21.02.2017 193 Support Status: Closed Solution: Yes tpilant


I followed instructions found in various FAQs regarding ProActive. It is not triggering on pages.

Also the contact form, Is this redirecting to a page with a contact form or an internal form. I set to redirect after a period of time, nothing happens. Does this take the place if fields in chat are not being used.

Anyway just putting things through the paces, trying to figure it all out. Realize your busy but any explantations on how to set these up and get them working would be greatly appreciated.

Thank You 

Terry Pilant


Replies (15)

  • avatar Jerome

    Good Morning.

    Thank you for your questions. Auto ProActive (engage customers) works once on the browser on the correct URL. It stores the result in a cookie to not trigger again and again. When you test make sure the URL you have set is the same displayed in the online user list.

    ***

    Contact form

    When there is a link set in the settings the chat will go this link after the time set above, for the slide up / out make sure the design is ready for the size of the slide up / out window. It might be better to use the internal contact form for the slide up / out window. It takes place when no operator picks up the chat.

    We are always here to help does not matter if we busy or not, our usual working hours are from 9am till 8pm (GMT +1) outside this hours we try to help whenever we can.

    Thank you very much.

    21.02.2017 0
  • avatar tpilant

    Still not undersatnding how to implement these. Nothing happens I have a contact form redirect, when I saty on the page pass the set time I do not get redirected to the conact form.

    As far as proactive perhaps I do not understand, I have tried in 4 different browser (so no cookies) existed. Does this show me who is on the page so I can engage?

    "When you test make sure the URL you have set is the same displayed in the online user list."??

    25.02.2017 0
  • avatar tpilant

    Not a problem on the contact form will do as suggested and use the internal form.

    Just need to wrap my head around the proactive.

    25.02.2017 0
  • avatar Jerome

    Good morning.

    First make sure you are running the latest version 3.0.3, we only support the latest version.

    The Engage (ProActive) hast two option.

    Auto ProActive:

    It will invite the user automatically to a chat depend on your settings. It will only run if an operator is online or the operator uses the business hours and the client is within the business hours. The Auto ProActive will fire once and store the result in a cookie.

    Manual Engage:

    Go to your online user list and all visitors on top are currently online you can manually invite them with clicking on the button on the right side. Four colours:

    • Grey (standard)
    • Yellow (invited)
    • Green (accepted)
    • Red (denied)

    Hope that helps to clarify.

    25.02.2017 0
  • avatar tpilant

    So I am meeting that criteria. But no online users show nor does the PA auto trigger either. Now I am testing from systems all on the same router could that not trigger or show an online users. I test with a notebook, tablet and phone (wireless connectivity) and all the other features work ok.

    These are my settings

    https://imunlmtd.com/9x12-billboard-advertising-mailer/

    Show Alert = Yes

    Time on site = 5 sec

    Pages = 1 visited

    Regards 

    Terry

    25.02.2017 0
  • avatar Jerome

    Are you running the latest version 3.0.3?

    25.02.2017 0
  • avatar tpilant

    Yes upgraded yesterday

    25.02.2017 0
  • avatar Jerome

    Can you invite me please, I'm testing with Firefox IP 90. You should see me in the online user list.

    25.02.2017 0
  • avatar Jerome

    I have found the bug in the cross domain file, I appologise for any inconvinience.

    That bug does not apply to LCPS.

    Please download the package from our download area: https://www.jakweb.ch/download/f/19/live-chat-3

    Unpack and replace following file: js/jaklcpchat.js

    Refresh the browser and ProActive should work as expected, that does not happen when the chat is used on the same domain.

    Thanks again for your patience.

    25.02.2017 0
  • avatar tpilant

    Thank you. 

    "that does not happen when the chat is used on the same domain".??

    25.02.2017 0
  • avatar Jerome

    The chat determines if the client is installed on the same domain or on a different domain (cross domain) for cross domain we need to run different requests because they not allowed like normal requests on the same domain.

    The software does that all automatically and when you replace the file above it should be fixed.

    All packages have been updated and it will be included in 3.0.4 of course.

    25.02.2017 0
  • avatar tpilant

    Cool that did it. Thanks again. 

    Quick question is there no longer support for uploading custom buttons?

    25.02.2017 0
  • avatar tpilant

    Well maybe spoke to soon It worked in MS Razor browser but not Chrome,IE or Firefox plus I still do not see online users. Anyway sun coming up...

    25.02.2017 0
  • avatar Jerome

    You will need to empty your browser cache, because you have changed a Javascript file it is cached on the browser and probably still uses the old one.

    You can not just upload buttons you can also upload slideup images all under your operator panel - buttons.

    Make sure your folder has the correct permission and you are uploading two buttons at the same time.

    https://www.jakweb.ch/faq/a/157/upload-buttons-slideup-images-live-chat-3

    25.02.2017 0
  • avatar Jerome

    Hi, everything OK?

    Thank you for your feedback.

    27.02.2017 0