Support Tickets - CMS 1.5.1 - Blog bug 5

CMS 1.5.1 - Blog bug 5

CMS 05.12.2015 595 Bug Report Status: Closed Solution: Yes bluesatkv


BLOG plugin TinyMCE for comments.

Language pack does not work.

Init TinyMCE is in 'usreditor.js'. Config for language is

language: jakWeb._lang,

but still not work.


Replies (4)

  • avatar Jerome

    Thank you for reporting this.

    We will fix the var within the next release.

    There is another thing because you are using a new language which did not exist before you also need to download the language pack from tinyMCE on their website. Download your language and place the file within:

    js/editor/langs

    Please make sure it has the same name as your language file, for example if it is called de.ini the language file for tinyMCE should also be called de.js and the first line inside the file should also be called 'de'.

    06.12.2015 0
  • avatar bluesatkv

    Jerome,

    In CMS 1.5.1 you have file 'cs.js' for TinyMCE for my language. But language not work.

    I think that is problem in configuration

    language: jakWeb._lang,

    For my language I use two files:

    • cs.ini in 'lang' folder
    • cs.ini in 'admin/lang' folder

    If I use config

    language: "cs",

    than TinyMCE editor works in language czech.

    Thanks for your support.

    06.12.2015 0
  • avatar bluesatkv

    Bug is in setting variable \'jak_lang\', script is in footer.php

    I move

    <script type="text/javascript">
     jakWeb.jak_lang = "<?php echo $site_language;?>";
    </script>;

    from footer.php to header.php.

    Than I edit usreditor.js

    language: jakWeb.jak_lang,

    And all is OK, TinyMCE have language by settings in ACP. laughing

    06.12.2015 0
  • avatar Jerome

    As I wrote above the rest has already been fixed and will be included within the next release.

    Thank you.

    06.12.2015 0