Support Tickets - Can’t achieve last step of installation wizard

Can’t achieve last step of installation wizard

CMS 09.02.2017 161 Support Status: Closed Solution: Yes Keepshango


Hello,

Please note that the followings were done on a remote server ; with domain name that I only use to test scripts installation :

I created a website (subdomain) and a database from control panel
I removed default “favicon“, “robots“, and “index“ flies from web root directory (chmod to 777)
I uploaded all content within “upload“ folder to web root directory
I chmod to 777 every folders and subfolders that were within “upload“ folder
I changed file “db.php.new“ to “db.php“
I set “dp.php“ file so it matches with the database created from control panel
*** And I also *** :
- define('DB_PASS_HASH', ‘XXXXXXXXXX’);
- define('FULL_SITE_DOMAIN', 'academie.uberknowledge.fr');
- define('JAK_USE_APACHE', 1);

Btw, I observed that when selecting the recursive mode “subfolders only“ from different FTP clients, all files were also affected ; so I chmod folders and subfolders one after the other….

I did all steps described above 3 or 4 times to test the script installation (and removed the “install“ folder after the second step of installation wizard is completed ), but I could never achieved the last step of the installation wizard.

******* FAILURES *******

*** 1 *** (script downloaded from codecanyon account weeks ago)
Once, I had to reset the database prefix setting as default (‘’) so I could access the dashboard directly (???) and logout. But when back to the login page, my password was not recognized, and secondly I was returned an error page when I clicked the link that I was sent by email to reset my password….

*** 2 *** (from script downloaded yesterday)
At another try, the wizard window invited me to do the last step but without showing none link to go further on ???

*** 3 ***
At the last try, the wizard window (first steps) shows ERROR MESSAGE : config.php not available!

Otherwise, cans I leave the database prefix in “db.php“ files as default (‘’), or does it require an entry (there is no field for such this entry on my control panel) ?

I have been searching what’s wrong during hours, but no success ; and I need to know exactly what to do because I will soon guide a friend that is interested in your product.

NEED YOUR HELP !

KS


Replies (13)

  • avatar Jerome

    Thank you very much for your ticket.

    As I understand you right you have set everything to 777? If so where did you read that?

    All files should have 644 all folders (except the _files folder) should have 755.

    Please change to the correct permission and try again.

    You don't have to use a database prefix. Database prefixes are useful if you share the dabase with another program.

    CMS should be installed on a sub domain or main domain only.

    09.02.2017 0
  • avatar Keepshango

    Hello,

    I knew that files and folders permissions should be set the way you said above....
    Now that permissions are set this way (at new), but wish to precise that I had to set “_files“ folder to 777 (and subfolders to 775) to pursue the installation wizard over the first step….

    However, I am still facing the same issue as above :
     
    *** 2 *** (from script downloaded yesterday)
    The wizard window invites me to do the last step but without showing none link to go further on (can’t click ???
    The link “Create admin“ is not activated !
    Please view browser image : http://docdro.id/dQgrXtu 

    Then I rewarded the installation wizard, and relaunched it ; and instead of the last step window, my browser points to this error page : http://docdro.id/dqcNO4U

    So frustrating ! Because it probably means that I will have to re-upload all the script folders to my web document root again, unless there is a way to restart the installation wizard without re-uploading the script ???

    STILL NEED HELP !

    These are my “db.php“ file settings :  
    // Database connection and setup
    define('DB_HOST', 'localhost'); // Database host ## Datenbank Server
    define('DB_PORT', 3306); // Enter the database port for your mysql server
    define('DB_USER', 'c1keoz'); // Database user ## Datenbank Benutzername
    define('DB_PASS', 'D8indo18'); // Database password ## Datenbank Passwort
    define('DB_NAME', 'c1fluvia'); // Database name ## Datenbank Name
    define('DB_PREFIX', ''); // Database prefix use (a-z) and (_), for example: cms_

    // Define a unique key for your site: (https://www.jakweb.ch/faq/a/99/database-and-password-hash)
    define('DB_PASS_HASH', ‘XXXxXxxxxXXx’);

    // Define your site url, for example: www.jakweb.ch (https://www.jakweb.ch/faq/a/98/full-site-domain)
    define('FULL_SITE_DOMAIN', 'academie.uberknowledge.fr');

    // Define cookie path and lifetime
    define('JAK_COOKIE_PATH', '/');  // Available in the whole domain
    define('JAK_COOKIE_TIME', 60*60*24*30); // 30 days by default

    // Apache or Not
    define('JAK_USE_APACHE', 1); // Use 1 for Apache (SEO URL's) or 0 for all others

    // Choose the files directory, rename it if you like different location but make sure the content is the same
    define('JAK_FILES_DIRECTORY', '_files');

    // Important Stuff
    define('JAK_SUPERADMIN', '1'); // Not deletable and SuperADMIN User, more user separate with comma. e.g. '1,4,5,6' (userid's)
    ?>

    Awaiting for help !

    KS

    09.02.2017 0
  • avatar Jerome

    Please send me FTP and control panel or mysql access to your server via following form: https://www.jakweb.ch/access-form

    Thank you.

    10.02.2017 0
  • avatar Keepshango

    Done !

    10.02.2017 0
  • avatar Jerome

    Thank you very much and sorry for the late reply it took a bit longer as usual.

    I have installed the CMS and the database and user looks alright. For some reason I cannot remove the install directory I have renamed the directory to install_old, please delete when possible.

    You can now login into your Administration panel here: http://academie.uberknowledge.fr/admin/

    Username: Keepshango
    Password: 12345678 (please change)

    To make the front end work please open your include/db.php file and change the rewrite to zero, I don't think your server likes it.

    // Apache or Not
    define('JAK_USE_APACHE', 0); // Use 1 for Apache (SEO URL's) or 0 for all othersyour

    Again I can't do it the FTP user account won't allow any changes.

    10.02.2017 0
  • avatar Keepshango

    Hello

    This is not what I expected... !
    Because as I said in the first post of this ticket, the server I granted you access to and the domain name are only use to test scripts.

    My wish is to know exactly what you’ve done, so I can redo it totally by myself to run and complete the script on my production server with another domain name :

    I observed that you changed permissions to 777 for all folders and subfolders within the “_files“ directory
    I observed that you changed the mysql user group setting to “3“ (like you advised me to do on a previous ticket)
    What else ???

    STILL FAILS
    I changed the APACHE setting to “0“ but I it doesn’t help to access the front end at all.
    - Clicking on “Mosaic CMS“ (upper left menu) points to a BLANK PAGE
    - Clicking any “Home“ tab points to the dashboard.  

    EMERGENCY
    I need SHOEX to be fully functional ASAP !
    I have an appointment next 18th February to help a friend who rely on me for a global work including SCHOEX (purchase and install…).

    Cordially,

    KS

    11.02.2017 0
  • avatar Jerome

    I could not change any folder permissions or removing any files. Luckely I could rename the install directory. That's it.

    Obviously something is wrong on your server but without having access to your error log files I can't really tell you what is wrong.

    The control panel is very limited (maybe just for me) but I really miss the error logs to determine what is going wrong on your server.

    11.02.2017 0
  • avatar Keepshango

    About one month earlier (first test), I could access the front end by changing the mysql user group setting from “1“ to "3“ (as you told me to do). But it is not sufficient today !?

    ******* Please find the ERROR LOGS of today hope it’s help *******
    [Sat Feb 11 06:25:04.732360 2017] [auth_digest:notice] [pid 22158] AH01757: generating secret for digest authentication ...
    [Sat Feb 11 06:25:04.742988 2017] [:notice] [pid 1687] FastCGI: process manager initialized (pid 1687)
    [Sat Feb 11 06:25:04.841520 2017] [:error] [pid 22158] python_init: Python version mismatch, expected '2.7.6', found '2.7.12'.
    [Sat Feb 11 06:25:04.849650 2017] [:error] [pid 22158] python_init: Python executable found '/usr/bin/python'.
    [Sat Feb 11 06:25:04.849685 2017] [:error] [pid 22158] python_init: Python path being used '/usr/lib/python2.7/:/usr/lib/python2.$
    [Sat Feb 11 06:25:04.849740 2017] [:notice] [pid 22158] mod_python: Creating 8 session mutexes based on 150 max processes and 0 m$
    [Sat Feb 11 06:25:04.849778 2017] [:notice] [pid 22158] mod_python: using mutex_directory /tmp
    [Sat Feb 11 06:25:04.901107 2017] [ssl:warn] [pid 22158] AH01906: vps356385.ovh.net:8080:0 server certificate is a CA certificate$
    [Sat Feb 11 06:25:04.901307 2017] [ssl:error] [pid 22158] AH02217: ssl_stapling_init_cert: can't retrieve issuer certificate! [su$
    [Sat Feb 11 06:25:04.901318 2017] [ssl:error] [pid 22158] AH02604: Unable to configure certificate vps356385.ovh.net:8080:0 for s$
    [Sat Feb 11 06:25:04.901496 2017] [mpm_prefork:notice] [pid 22158] AH00163: Apache/2.4.18 (Ubuntu) mod_fastcgi/mod_fastcgi-SNAP-0$
    [Sat Feb 11 06:25:04.901518 2017] [core:notice] [pid 22158] AH00094: Command line: '/usr/sbin/apache2'
    [Sat Feb 11 06:25:04.901639 2017] [mpm_prefork:warn] [pid 22158] AH00167: long lost child came home! (pid 16039)

    KS

    11.02.2017 0
  • avatar Jerome

    That has been fixed a while ago and all up to date installations will set the usergroupid correctly from start.

    Please call the front end and right after check the error log files, I can't see anything wrong at this point.

    11.02.2017 0
  • avatar Keepshango

    I did as you advised, but the ERROR LOGS informations are still the same....

    I am so disappointed because I previously was already refunded from my purchase of another website builder (from codecanyon as well). But I have no other alternative than to ask for a refund again.

    Cordially

    KS

    11.02.2017 0
  • avatar Jerome

    I don't know because you have purchased with CodeCanyon and not with us you might need to ask Envato.

    Please make sure you delete all copies as well when you ask for a refund.

    If you have problems in the past, you might consider to change the host as this is the problem and not our software. I can assure you our software runs on 1000s of different servers and we do not have any problems with it. We also only use standard functions that every web hosting company uses to avoid such things you have.

    11.02.2017 0
  • avatar Keepshango

    I will of course ask envato for a refund.

    Btw I own a remote virtuel private server (VPS) subscribed on OVH (most used french host provider).

    Thanks anyway for your reactivity !

    KS

    11.02.2017 0
  • avatar Jerome

    No problem.

    *** Ticket closed ***

    11.02.2017 0