Support Tickets - Directory/URL path bugs on login and home pages

Directory/URL path bugs on login and home pages

CMS 11.12.2016 248 Bug Report Status: Closed Solution: Yes Keepshango


Hello,

Prior to give you the bug description, please note DIRECTORY and URL paths that may help to understand what goes wrong.
The script is located in a folder that I self named "cms1", and was installed through an automatic generated directory path by "ISP Config3" control panel : var/www/clients/client1/web3/web/cms1

In the "db.php" file the URL is set to : http://www.mysite.com/cms1

*** NOTE 1 (bug)
I can't access the CMS admin login page directly with the URL : www.mysite.com/cms1/admin/
Once the loin button is clicked (credentials ok) I am firstly redirect to an ERROR PAGE (ADDRESS NOT FOUND) that the URL path is presented with 2 anomalies :

http://http//www.mysite.com/cms1/cms1/admin/
- http://http// ?
- /cms1/cms1 ?

To access the CMS dashbord, I have to additionnaly browse back one time !
Then the dashboard is displayed, and the browser URL field is showing the same entry as the one entered earlier to access the login page ?

*** NOTE 2 (bug)
Once within the CMS, when I try to acces my default home page from the menu, or when I want to log out I am redirected to the same ERROR PAGE (same URL as well).

*** NOTE 3 (home page location) !
However, the "HOME" page is displayed in plain text when the URL entry is : http//www.mysite.com/cms1/

******* QUESTIONS *******
Note 2 : it seems that something needs to be corrected, but I don't kow what and where !
Note 3 : could it be that the home page is displayed in plain text because JS, CSS3, and HTML5 are maybe not enabled on my apache server ?

Awaiting for some help and guidance asap !

KS


Replies (18)

  • avatar Jerome

    Hi,

    Do not run the CMS in a sub folder, run it in the main or subdomain and all your problems will go away.

    CMS has not been designed to run in a subfolder.

    Your full site domain does only contain the domain no subfolders, please check following FAQ article for more information: https://www.jakweb.ch/faq/a/98/full-site-domain

    11.12.2016 0
  • avatar Keepshango

    Hello,

    I did apply changes as advised in your previous reply (see below), but I CAN'T ACCESS the CMS login page and content any more now (see the browser connection failure outputs here under) !

    *** CHANGES
    In the "db.php" file, I changed the domain entry to 'www.mysite.com' (without http) and replaced the CMS source code in the web root location (not in subfolder). The initial "favicon.io" and "robots.txt" files in the web root folder were replaced by other ones from the CMS

    *** CONNECTION TESTS
    I tried to connect twice to www.mysite.com :
    - With the initial "index.html" file not removed from within the web root folder
    - With the initial "index.html" file removed from within the web root folder

    *** CONNECTION FAILURE / OUTPUTS
    www.mysite.com > default welcome message
    www.mysite.com/index.html > default welcome message
    www.mysite.com.info/index.php > Not Found (www.lafluviatheque.info/404)

    *** QUESTIONS
    Could it be that a "." or a "/" is missing or must be removed somewhere ?
    If not, where else could I have done wrong ?

    Awaiting for help and guidance asap

    KS

    13.12.2016 0
  • avatar Jerome

    Good Morning,

    When you have another website in your root you will overwrite it and you will probably run into a conflict. The installation should be in a empty root or sub domain.

    When you have an index.html file in your root your server will probably choose the index.html file (can be changed in the server settings). Remove the index.html file and CMS will work again (front end).

    The administration panel should work anyway: www.yourdomain.com/admin

    13.12.2016 0
  • avatar Keepshango

    Good morning too,

    I did removed the default "index.html" file, and there was previously nothing (no website) but the default content in the web root folder (see picture) : http://docdro.id/s0nyYa7

    *** WORKS / NOT WORKS
    Login as admin works
    Home page URL acess works : www.mysite.com
    But home page link from within the CMS does not work (nothing happens) !

    *** QUESTIONS
    Do I still have to change some settings in control panel (as you suggested) ?
    Could this change be a satndard redirection like : www.mysite.com/index.php ?

    KS

    13.12.2016 0
  • avatar Jerome

    In your include/db.php file what is your setting for:

    define('JAK_USE_APACHE', 0);

    If set to 1 do you have the .htaccess file placed in the root as well?

    https://www.jakweb.ch/faq/a/145/rewrite-or-pretty-url-s

    13.12.2016 0
  • avatar Keepshango

    JAK_USE_APACHE It is set to "1"

    I red the info from the provided link , and found the ".htaccess"

    Do I place it int the "web root" folder ?

    Do I also place in the "operator" folder (can't find such folder) ?

    KS

    13.12.2016 0
  • avatar Jerome

    Only in the web root, not in the admin folder.

    13.12.2016 0
  • avatar Keepshango

    I did placed the ".htaccess" file in the "web root" folder, and rewrite mode is enabled on my apache server.

    But the problem remains the same : the home page link from within the CMS does not work (nothing happens) !

    Do I have to modify an entry in the ".htaccess file", or is something have to done on server side ?

    If not what could prevent the link to work ?

    13.12.2016 0
  • avatar Jerome

    Please tell the URL to your installation. Thank you.

    13.12.2016 0
  • avatar Keepshango

    Maybe "Home" stands for dashboard when within the CMS.
    And maybe the "Home" frontend page can only be acessed via URL : www.mysite.com

    If not : what is not working ?

    KS

    13.12.2016 0
  • avatar Jerome

    To open the front end from the administration panel, please click on your website title above the Home.

    13.12.2016 0
  • avatar Keepshango

    My website name does not appear !
    But I could open the front end home page from the admin panel by clicking "Modern CMS" on the top of the vertical left menu.

    Maybe that I can rename "Modern CMS" to my convenience, or place my logo instead (in the admin panel).
    I tried to do so from the "general settings", but I could not find any corresponding option or parameter.

    Any further info to achieve this ?

    KS

    13.12.2016 0
  • avatar Jerome

    That is your website title. It can be changed under Site right under Home.

    13.12.2016 0
  • avatar Keepshango

    Hello,

    I completly reinstalled the CMS as a subdomain : beta.mysite.com
    Since this was done, I am facing at new URL/Directory path bugs from within the admin panel

    *** 2 LINKS BUGS ***
    When I click on my "site name", I am redirected to "mysite.com" (default welcome) instead of "beta.mysite.com" (home page).
    When I click on "save" (to validate site renaming), I am redirected to mysite.com/admin/index.php (error 404)

    *** MY GOAL ***
    - Website "mysite.com" has different content from website "beta.mysite.com" to be build with the CMS
    - One does not have to point the other.

    *** QUESTIONS ***
    Could the problem occure because of the subdomain or its "beta" prefix (beta.mysite.com) ?
    How to have the CMS admin (beta.mysite.com/admin) pointing to "beta.mysite.com" (home page) ?

    Cordially,

    KS

    14.12.2016 0
  • avatar Keepshango

    I forgot to precise that the "home" page may actually be displayed (in plain text) only with a URL entry in the browser field : beta.mysite.com.

    KS

    14.12.2016 0
  • avatar Jerome

    Please open your include/db.php file and adapt the full site domain.

    14.12.2016 0
  • avatar Keepshango

    Thanks !

    I should have guessed that this was the thing to do....

    This ticket can be closed now.

    14.12.2016 0
  • avatar Jerome

    Thank you for the feedback.

    *** Ticket closed ***

    14.12.2016 0