Support Tickets - htaccess and more errors

htaccess and more errors

CMS 17.06.2016 470 Support Status: Closed Solution: No joebloggs


Hi Support,

the installation hasn't gone as smothly as it seems to and I'm getting a lot of errors. My server details are below.

Install Issues

1. htacess is blank and I tried the code at https://www.jakweb.ch/faq/a/68/cms-and-htaccess-seo without luck, in fact it throw an error - 403 forbidden.

2. css - some of the css is not pulling the images, not sure what file?

3. the "advanced editor" wouldn't show at all, when I turned off the bootstrap editor appears (this is better anyway but still!)

Domain - ecommercetemplates.com.au
Apache Version - 2.2.31
PHP Version - 5.4.45
MySQL Version - 5.6.30
Operating System - linux


Replies (7)

  • avatar joebloggs

    I've made a small change which appears to have resolved the missing css, I midified the db.php file FULL_SITE_DOMAIN

    17.06.2016 0
  • avatar Jerome

    Good morning, that is correct with a wrong full site domain CMS wont work at all. More information can be found here: https://www.jakweb.ch/faq/a/98/full-site-domain

    Please let me know if you have any other issues.

    17.06.2016 0
  • avatar joebloggs

    Jerome, this didn't resolve issue 1.

    please advise?

    17.06.2016 0
  • avatar Jerome

    Ok, when you download the package you will have a folder called htaccess in this folder you will have a file (on some OS this file is hidden). The content of this file at minimum needs to look like this:

    RewriteEngine ON

    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . index.php [L]

    ErrorDocument 404 /404/

    It has to have the name .htaccess and needs to be in the root of your CMS installation. Also important do not install CMS in a sub folder only in the main or sub domain.

    Also important in your include/db.php file please change JAK_USE_APACHE to following:

    define('JAK_USE_APACHE', 1); // Use 1 for Apache (SEO URL's) or 0 for all others

    This will only work on apache servers and not on nginx or windows servers. Also the mod_rewrite module has to be installed. Also very important check your folder 0755 and file 0644 permissions (except your _files folder) otherwise you can have other errors.

    17.06.2016 0
  • avatar joebloggs

    that worked thanks.

    I do have an image problem still.

    I've turned off and on hotlinking but doesn't help

    if I go to page source and click the link, it redirects images to the 404 error page.

    I've confirmed the path is correct to the /_files/ directory and that images do appear, The directory is CHMOD to 755eg.

    I've also done a couple of other tests to make sure hotlinking isn't the issue when having hotlinking to off

    http://ecommercetemplates.com.au/loader.gif

    http://ecommercetemplates.com.au/test/loader.gif

    any suggestions?

    17.06.2016 0
  • avatar Jerome

    I receive on all images a internal error 500, please check your log files for more informations.

    17.06.2016 0
  • avatar Jerome

    I can still see an internal error 500, can I help you with anything?

    27.06.2016 0